Performance Issue affecting many users
Incident Report for Voyce System Status
Resolved
This incident has been resolved and wait times have returned to normal.
Posted Feb 12, 2024 - 13:10 EST
Investigating
We are experiencing an unexpected system slowdown affecting routing on our interpretation platform. This may impact your ability to connect to or continue interpretation sessions. During this slowdown, sessions may experience high latency/wait times or disconnect.

Our technical team is fully engaged and working to identify the root cause to then resolve this issue as swiftly as possible.
Posted Feb 12, 2024 - 12:54 EST
This incident affected: Interpreter Service and Management Portal.